PassMark Software
LOGIN   |    MY CART

Windows USB 3.0 Application Programming Interface (API)

USB 3.0 Application Programming Interface (API)

Windows Console Application

Linux USB 3.0 Application Programming Interface (API) Guide

Related hardware
USB3.0 Loopback plugs

Related donwloads
USB 3.0 Device Drivers and Documentation

The free USB3 Application Programming Interface has been designed to allow access by third party programs to the PassMark USB 3.0 loop back plug. It provides several functions to communicate with the USB3 loop back plugs as an easy way to use the plugs without having to write any device driver or extra firmware code.

The API will allow software developers to integrate the USB test plug seamlessly into their own applications.

The usb3api_v2.1003.zip* file contains:

The USB3 API can only be used with the PassMark USB 3.0 loop back plug.

System Requirements

The API has been designed and tested to run on Windows 7, 8 & 10. Other operating systems are not supported. The example source code was built using Microsoft Visual Studio 2013. The Cypress EZ-USB FX3 SDK is required to compile and run the demo program.

Windows Console Application

We have developed a Windows console application which helps to automate testing on USB ports. The application gets some input parameters such as device serial number, speed at witch the port should be tested, test duration etc. At the end of the test, results are written to the standard output.

You can download the latest copy of our console application from here.

System Requirements

The console application has been designed and tested to run on Windows 7, 8 & 10. Other operating systems are not supported.

Linux & Mac USB 3.0 Application Programming Interface (API) Guide

We have developed a tutorial package which demonstrates how to use the libusb library to communicate with USB 3.0 Loopback plugs in Linux. This package includes a manual plus some demonstration source code explaining the usage of functions in the library. This can also be used on Mac systems that have libusb installed.

You can download the latest copy of our Linux USB 3.0 API package from here.

System Requirements

Our Linux API tutorial package requires a Linux environment with the 1.0 version of libusb installed.