PassMark Software

Announcement

Collapse
No announcement yet.

WirelessMon 3.0 and Vista crashes

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • WirelessMon 3.0 and Vista crashes

    We have identified a bug in version 3.0 where if you are connected to an access point and the connection is lost it could cause WirelessMon to crash.

    If you are experiencing crashing in Vista there is a beta build for the next release available from http://www.passmark.com/ftp/wirelessmon3.0.1001beta.exe, please try this build and let us how it goes.

    Update: Aug 2009 - These issues should all be resolved in the V3.1 release.

  • #2
    Hey TimR,

    i'm trying your software but it is crashing all the time. I'm using this Beta from this thread here. The Error is named: Access violation at 0x774b2591 (tried to read from 0xf4f1a04), program terminated.

    Once the software started but it crashes immediately. I'm looking forward to hear from you.

    Regards,
    trashboat

    Vista Business & Intel ABGN WiFi
    Last edited by trashboat; 05-10-2008, 02:35 PM.

    Comment


    • #3
      My WirelessMon 3.0 and Vista crashes too!!!!

      I have one of two symptoms.... Either it starts up and runs until you click on it or 15-30 seconds pass and it crashes. The other symptom is the Access Violation error....

      The Vista Problem Details (or App event log) show...

      Problem signature:
      Problem Event Name: APPCRASH
      Application Name: WirelessMon.exe
      Application Version: 3.0.0.1001
      Application Timestamp: 4823a6b0
      Fault Module Name: StackHash_a621
      Fault Module Version: 6.0.6001.18000
      Fault Module Timestamp: 4791a7a6
      Exception Code: c0000374
      Exception Offset: 000b015d
      OS Version: 6.0.6001.2.1.0.256.1
      Locale ID: 1033
      Additional Information 1: a621
      Additional Information 2: 4c5352a606092bf2198155013d37e498
      Additional Information 3: 6970
      Additional Information 4: 8fe3b983a3605d12b5bcdfb54a7f8114


      This is a great application and it's causing me pain not to be able to use it!!!

      This all started sometime in the past week or 2....if its the same time frame as others, could it be an update of some kind???

      Comment


      • #4
        It seems that Vista SP1 has changed some of the underlying system functions that WirelessMon uses and is causing it to crash. We are still trying to figure out why SP1 is causing the crashes and the minute we do i'll put up a new debug build.

        Comment


        • #5
          There is a new build debug build available, if you are having problems with running WirelesMon on Vista please download http://www.passmark.com/ftp/wirelessmon3.0.1001beta-b.exe and let us know if it has/hasn't fixed your issues.

          Comment


          • #6
            Also if you do get a crash, you will often see a window asking you to submit the error to Microsoft. PLEASE DO THIS.

            When you get the error (from the error Window, select the "Send Error Report" button). We can collect this detailed crash information from Microsoft and this will give us more information about the problem.

            Comment


            • #7
              Downloaded the new version of WMon but it didn't fix the violation error and i cannot click the send report to microsoft button because it didn't exist in this window. I think it's not a SP1 problem because i haven't got Vista SP1 (Vista OEM) . Hope you will find a way around this problem. It's a very nice program!

              Comment


              • #8
                After the initial crash window there should be a "Check for solutions" window displayed, if you click the check button it should send a report to Microsoft.

                Comment


                • #9
                  There is a new build available from http://www.passmark.com/ftp/wireless...1001beta-c.exe.

                  Comment


                  • #10
                    There is another new build available http://www.passmark.com/ftp/wireless...1001beta-4.exe.This fixes a subtle bug in the access point detection update loop which caused a number of crashes in Vista. The software was crashing if a new access points appeared while we were already half way through getting the list if available access points. So wireless cards / PC's that were slow to report data were more impacted as there was more chance the list would change in the middle of an update. Hopefully this is fixed now.

                    Comment


                    • #11
                      The new build is now available from www.passmark.com/ftp/wirelessmon.exe, the release notes are;

                      • Improved stability in Vista and Vista SP1
                      • Fixed a crash when using the mapping and GPS function, if the GPS returned a 0 (no position) value a crash could occur when updating the last GPS position indicator on the map
                      • Fixed a bug with the General options window having the window title incorrectly set
                      • Fixed Tab order for connection manager dialog and access point connection dialog
                      • Fixed an error message displayed about a missing Wirelessmon file when connecting to an access point in Vista
                      • Fixed a bug where the saved connections file could be held open by WirelessMon
                      • Fixed a bug with some supported rates not displaying correctly
                      • Fixed a crash in Vista caused when the access point currently connected to went out of range

                      Comment

                      Working...
                      X