PassMark Software

Announcement

Collapse
No announcement yet.

OSFMount - commandline problem

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • OSFMount - commandline problem

    Hello, I want mount virtual usb drive wiith OSFMount automatically at start of windows, so I am trying to create .bat file with proper commandline params of OSFmount.com. But when I execute my command line, USB image is mounted but without any content - similar behavior like whe I do it in GUI app and I have not selected "Mount all partitions". So my question is: how to set "Mount all partitions" in commandline?

    My commandline:
    OSFMount.com -a -t file -f c:\temp\USB.bin -m F: -o rem,rw,hd

    I already tried to play with -v param but with -v 0 i got only help text and with -v 1 i got message: Error: Partition table not found

    Note. USB image was created with ImageUSB
    Thx for help

  • #2
    USB drives don't normally have partitions. So maybe there are no partitions? As this would also explain the 'Partition table not found' message.

    Comment


    • #3
      Hi

      Originally posted by Hopik View Post
      Hello, I want mount virtual usb drive wiith OSFMount automatically at start of windows, so I am trying to create .bat file with proper commandline params of OSFmount.com. But when I execute my command line, USB image is mounted but without any content - similar behavior like whe I do it in GUI app and I have not selected "Mount all partitions". So my question is: how to set "Mount all partitions" in commandline?

      My commandline:
      OSFMount.com -a -t file -f c:\temp\USB.bin -m F: -o rem,rw,hd

      I already tried to play with -v param but with -v 0 i got only help text and with -v 1 i got message: Error: Partition table not found

      Note. USB image was created with ImageUSB
      Thx for help
      try a partition manager lile gparted:

      http://gparted.org

      make a small partition like 1 mb and a second one with hole rest format last one with filesystem you need
      now the Stick have a partition Table, try again a mount be aware that you must use partition 1 (normal start with zero) if that not work try 2

      best

      Andre

      Comment

      Working...
      X