PassMark Software

Announcement

Collapse
No announcement yet.

List of Motherboards with issues when running MemTest86 in multi-CPU selection modes

Collapse
This is a sticky topic.
X
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • List of Motherboards with issues when running MemTest86 in multi-CPU selection modes

    Due to a number of users having issues with certain motherboards (BIOS) not being able to run MemTest86 using CPU selection modes other than Single CPU (ie. Parallel, Round Robin, Sequential), we have compiled a list to track the motherboard model and BIOS versions with problem firmware. This list shall be updated as more motherboards with buggy firmware are discovered, or if there is an updated BIOS available that fixes the problem.

    If you are having similar issues with certain CPU selection modes and your motherboard is not on the list, please post the following details so that we can add it to the list:
    • Motherboard model number
    • BIOS version
    • CPU
    • Summary of the issue you are experiencing
    Motherboard BIOS version CPU Notes
    ASRock 970M Pro3 1.30 AMD Phenom II X6 1090T BE Freeze on Parallel, Sequential, Round Robin.
    Freeze on Single for all CPUs except CPU0
    Reference
    Asrock 970 Extreme3 R2.0 1.6 to 2.2 AMD Phenom II X2 550 Freeze on Parallel, Sequential, Round Robin.
    Freeze on Single for all CPUs except CPU0
    Reference
    ASRock P67 Extreme6 ? ? Parallel runs fine (4 passes without problems)
    Freeze on Sequential after test 1 (after CPU core switch)
    Reference
    HP 15-ab153nr F.13 AMD Quad-Core A10-8700P APU Freeze on Parallel, Sequential, Round Robin.
    Especially CPU1 on Test 3
    Reference
    Gigabyte GA-Z97MX-Gaming 5 (1.0) F4 Intel I7 4790K Freeze on Sequential, Round Robin when cycling through the CPUs. Eg. 0 -> 1 -> 2 -> ... n -> 0 -> 1 [Freeze]
    Reference
    Gigabyte GA-Z170MX-Gaming 5 (rev. 1.0) F4 & F5e (BETA) Intel i5-6500 [Single] Runs fine on CPU0, all other CPUs goes to start the test and restarts right away
    [Parallel] Runs on CPU0 but says "[CPU Error] Could not start CPU 1-3"
    [Round Robin] Immediately restarts on first test attempt
    [Sequential] Same as Round Robin
    Reference
    Gigabyte GA-Z170X-Gaming 7 F6 Intel i7-6700K [Single] Runs fine on CPU0, all other CPUs goes to start the test and restarts right away
    [Parallel] Runs on CPU0 but says "[CPU Error] Could not start CPU 1-7"
    [Round Robin/Sequential] Runs the first 3 tests on CPU0 then restarts maybe the moment it tries to go to the next CPU
    Reference
    Gigabyte GA-Z170X-Gaming GT F6
    F7
    Intel i7-6700k [Single] Runs fine on CPU0, all other CPUs goes to start the test and restarts right away
    [Parallel] Runs on CPU0 but says "[CPU Error] Could not start CPU 1-7"
    [Round Robin/Sequential] Runs the first 3 tests on CPU0 then restarts maybe the moment it tries to go to the next CPU
    Reference
    Gigabyte GA-Z170X-UD3 F6 Intel i5-6600K Cannot switch BSP to another CPU other than 0
    Cannot start any APs in parallel mode.
    Reference
    Gigabyte GA-Z170-HD3P F5 Intel i5-6600K WhoAmI failed
    Cannot start any APs in parallel mode.
    After updating the motherboard firmware to F20 (Release Date Nov 9, 2016) MemTest86 ran in multi-core mode.
    GA-H170-D3HP F4 Intel i3-6100 WhoAmI failed
    Cannot start any APs in parallel mode.
    Gigabyte GA-990FXA-UD3 (rev. 4.0) F3 AMD FX 9590 Freeze on test 3 using CPU 0.
    Hangs on any other processor.
    Reference
    Gigabyte 990FXA-UD5 ? AMD FX 4350 4.2 Quad Core & AMD FX 8350 Freeze on Parallel, Sequential, Round Robin
    Reference

    Unexpected RAM errors on test 3 and generally unstable motherboard when in parallel mode.
    Reference

    Freeze / Hang in parallel mode. But single CPU modes run OK. Turned out not to be a BIOS issue, but user pushed a CPU overclock too far. Reverting to stock clock speeds fixed problem. Reference.
    Gigabyte GA-970A-DS3P v2.0 FC AMD Phenom II x4 945 CPU Freeze on Parallel, Sequential, Round Robin.
    Freeze on Single for all CPUs except CPU0
    Reference
    Gigabyte X99 Ultra Gaming
    X99-Ultra Gaming-CF
    F4

    F6
    5820K

    i7-6850K
    Unspecified multi-threaded problem.
    Reference
    Freeze on Test 2 in parallel mode
    Reference
    ASUS M5A97 R2.0 ? AMD FX-8350 Freeze on Sequential and Round Robin.
    Timeout and Errors in Parallel Mode
    Reference
    Unofficial BIOS fix from ASUS
    Asus M5A97 Evo R2.0 2603 AMD FX-8300 Freeze on Sequential and Round Robin.
    Timeout and Errors in Parallel Mode
    Reference
    Unofficial BIOS fix from ASUS
    ASUS M5A99FX PRO R2.0 2501 AMD FX-8370 Freeze on MP test on startup
    ASUS 970 PRO GAMING/AURA 0501 AMD FX-8320E Crash in Parallel Mode
    Official BIOS fix from ASUS
    Asus X99-A II 0601 Intel i7-6850K Crash in Parallel Mode.
    Single, Sequential and Round Robin OK
    Official BIOS fix from ASUS
    Asus X99-A/USB 3.1 ? Intel Core i7-5930K Freeze during Parallel Mode.
    MP test passed during startup
    Official BIOS fix from ASUS
    ASUS X99-E WS ? Intel Xeon E5-2630 v4 Freeze on Sequential, Round Robin and Parallel Mode.
    Single CPU Test OK
    ASUS Strix X99 Gaming 1401 Intel Core i7-6800K Freeze on multiprocessor test on startup
    Reference
    Official BIOS fix from ASUS
    ASUS ROG STRIX X99 GAMING 0801 Intel Core i7 for LGA 2011-v3 Freeze on Sequential, Round Robin and Parallel Mode.
    Single CPU Test OK
    Reference
    Official BIOS fix from ASUS
    ASUS SABERTOOTH X99 3301 Intel i7-5820K Freeze on Sequential, Round Robin and Parallel Mode.
    Single CPU Test OK
    Reference
    Official BIOS fix from ASUS
    ASUS X99-DELUXE II 1504 Intel Core i7-6950X Freeze on Sequential, Round Robin and Parallel Mode.
    Single CPU Test OK
    Official BIOS fix from ASUS
    ASUS X99-DELUXE 3505 Intel Core i7-5930K Freeze on Sequential, Round Robin and Parallel Mode.
    Single CPU Test OK
    Official BIOS fix from ASUS
    ASUS RAMPAGE V EXTREME 3402 Intel Core i7-5960X Failed multiprocessor test on startup
    Freeze on parallel, sequential, round robin.
    No problem in Single CPU.
    Reference
    BIOS fixed in release 3701 - 2017/06/09
    ASUS ROG Rampage V Edition 10 1003 Intel Core i7-6950X Freeze on Sequential, Round Robin and Parallel Mode.
    Single CPU Test OK
    Reference
    Official BIOS fix from ASUS
    Asus Z10PE-D8 WS ? ? Freeze during Parallel Mode.
    MP test passed during startup
    ASUS MAXIMUS VIII RANGER 3007 Intel Core i7-6700K Single-core and all-cores tests run with no problems
    Freeze on Sequential, Round Robin.
    Reference
    ASUS PRIME B350-PLUS 0503
    0513
    0605 (Beta)
    AMD Ryzen 7 1700 Eight-Core Freeze during multiprocessor initialization (EnableDisableAP)
    Reference
    ASUS CROSSHAIR VI HERO 1107 AMD Ryzen 7 1800X Freeze during multiprocessor initialization (EnableDisableAP)
    Official BIOS fix from ASUS
    ASUS ROG STRIX X370-F GAMING 0902 AMD Ryzen 7 1700 Freeze during multiprocessor initialization (EnableDisableAP)

    (Update: Appears to be fixed in version 4012)
    Supermicro X9DRW-iF R3.2 Intel Xeon E5-2680 V2 Freeze on Sequential and Round Robin.
    Reset on Parallel Mode.

    Single CPU Test OK
    Supermicro X9DRW-3LN4F+/X9DRW-3TF+ 1.20 Intel Xeon E5-2640 Failed multiprocessor test on startup
    Reference
    Supermicro X9SRL-F ? Intel Xeon E5-2670 v2 Hangs on AP test on startup
    Reference
    Supermicro X9SRA//X9SRA-3 R 3.2 Intel Xeon E5-1620 PC shuts down and reboot after "Testing multiprocessor support"
    Reference
    Supermicro X10SRA 2.0c (25th Sep 2017) Intel Xeon E5 2630 V3 Hangs at startup unless single threaded.
    Reference
    EVGA X99 FTW K 2.02 Intel Core i7-6800K Hangs on AP test on startup
    MSI X399 SLI PLUS 7B09vA6 AMD Threadripper 1950X Freezes in parallel mode on test 3 (Own address, Parallel)
    Reference
    Last edited by keith; Yesterday, 11:47 PM.

  • #2
    Hi,

    Freeze on Parallel, Sequential, Round Robin.
    Freeze on Single for all CPUs except CPU0


    is happening on the Gigabyte GA-970A-DS3P v2.0 motherboard with the FC BIOS and AMD Phenom II x4 945 CPU too.

    Comment


    • #3
      Hi everybody,

      -Gigabyte GA-Z170X-UD5
      -BIOS "F4"
      -Intel i7-6700k
      -Freeze on Parallel, Sequential, Round Robin. Freeze on Single for all CPUs except CPU0

      Runs fine on CPU0, all others insta-crash and reboot


      Comment


      • #4
        Another board with the same/similar issue

        Asus M5A97 Evo R2.0 wiht BIOS version 2603

        CPU: AMD FX-8300
        RAM: 4x8=32GB Kingston HyperX Fury DDR3-1866

        everything OK outside Parallel/Robin parameter (MEM is good with single CPU test and is working when using Parallel but in old MT86 4.3.7)
        Last edited by mig; 02-18-2016, 03:49 PM.

        Comment


        • #5
          Mainboard: Supermicro X9DRW-iF
          BIOS: R3.2
          CPU: 2x XEON E5-2680 V2
          Reset on Parallel Test
          Freeze: Round Robin
          works ok: single CPU Test

          We buy the pro version to test our compiler server. And this is a pain in you the know what i mean.

          Christian

          Comment


          • #6
            Hi
            here are my finds

            -Gigabyte GA-Z170X-Gaming 7
            -BIOS "F6"
            -Intel i7-6700k

            MemTest 6.3.0 Free

            -Single Cpu - Runs fine on CPU0, all other CPUs goes to start the test and restarts right away
            -Parallel - Runs on CPU0 but says "[CPU Error] Could not start CPU 1-7"
            -Round Robin - runs the first 3 tests on CPU0 then restarts maybe the moment it tries to go to the next CPU
            -Sequential - just like Round Robin

            MemTest 4.3.7

            no such problems
            Last edited by NikoKiko; 03-27-2016, 10:06 PM.

            Comment


            • #7
              Add me to the list of systems that fail using MemTest 6.3.0. I'm booting from a memory stick. Here's my system:
              Gigabyte GA-990FXA-UD3 vers 4.0
              Bios F3 dated 5/28/15 (latest)
              AMD FX 9590 8-processor CPU
              16GM
              Corsair Vengeance Red 8GB (2x4GB) DDR3 1866 MHz (PC3 15000) Desktop Memory (CMZ8GX3M2A1866C9R)
              h100i cooler
              Samsung SSD + HDDs

              I have not been able to complete even 1 test using 1 processor. It always seems to stop on test 3 using CPU 0. If I try to use a different processor (ie, CPU1, etc), then nothing happens, it just hangs. If I run the Microsoft Memory Test, that works fine, but it does not give me the option to use other processors.

              I've been running this test off and on for the past 3 wks. I even bought new memory since the Ballistic memory I had been using was not listed as supported even though it seems to work OK in normal operation.

              Let me know if you are interested in getting my log file to see what's going on. It seems it is too big to add in-line to this message, and the system will not accept a TXT file.

              I have not tried to contact Gigabyte, although from what I've read in this forum they are not likely to admit to a problem.

              Comments?
              Thanks,
              Tony




              Comment


              • #8
                Tony,

                Thanks for the details. Yes, if possible, please e-mail us a copy of the log file.

                Comment


                • #9
                  Hi,
                  similar problem with stock settings - only CPU0 is working:
                  Gigabyte Z170X-UD3 BIOS F6
                  Intel i5-6600K
                  Kingstone 4x4GB (2x kit 8GB) HX430C15SB2K2/8
                  MemTest86 V6.3.0 Free Build: 1000 (64-bit)
                  Log file https://drive.google.com/file/d/0B4l...ew?usp=sharing

                  In MemTest86 Version 4.3.7 test passed 7times with all CPUs (parallel) over night.

                  Stibi
                  Last edited by stibi; 04-26-2016, 04:51 AM.

                  Comment


                  • #10
                    Update: We have purchased a ASUS M5A97 based machine to test on in house.
                    So hopefully we'll find find a work around for the BIOS bug.
                    (and then hope the same work-around also fixes the Gigabyte BIOS issue)

                    We should have a new software release to try out in a couple of weeks (mid May 2016)

                    Comment


                    • #11
                      MemTest V7 beta is now out. This release has a work around / detection method for the above UEFI bug.

                      The behaviour in V7 is to try and detect the above bug and if detected the machine will only be run in single threaded mode. If the machine seems bug free, and supports threading, we run in multithreaded mode.

                      This means that V7 will now default to multithreaded testing. Running in parallel mode significantly decreases the test time as compared to running in single CPU mode and should also help to detect more errors faster.

                      We have also reported the problem to ASUS and they have indicated that they have a look at it with a view to fixing it.

                      We are sure at this point if this will also solve the problem with the ASRock boards and Gigabyte board. Fingers crossed it will.

                      Comment


                      • #12
                        -Gigabyte GA-Z170X-Gaming GT
                        -BIOS "F6"
                        -Intel i7-6700k

                        MemTest 6.3.0 Free

                        -Single Cpu - Runs fine on CPU0, all other CPUs goes to start the test and restarts right away
                        -Parallel - Runs on CPU0 but says "[CPU Error] Could not start CPU 1-7"
                        -Round Robin - runs the first 2 ests on CPU0 then hangs PC
                        -Sequential - just like Round Robin

                        Comment


                        • #13
                          ASUS got back to us and has confirmed is is a firmware bug in the M5A97 R2.0 motherboard. We tested updated firmware and confirmed it does correct the problem.

                          The new firmware version we tested was called "M5A97-R20-ASUS-9001.CAP"

                          However the current public release on the ASUS site seems to be BIOS M5A97-R20-ASUS-2603.CAP. (Version 2603 from July 2015). So who knows if this 9001 release will ever be made public, or if it gets renamed before being released.

                          Still, nice to know it really was a firmware bug and not something wrong in MemTest86.

                          Seemingly they aren't proactively fixing other motherboards. We asked them to make the same correction to the other ASUS motherboard with the same problem, like the M5A97 Evo R2.0, but they instead asked us to fill out more customer feedback forms
                          We don't have test hardware for these other boards, so can't test a fix in any case.

                          Comment


                          • #14
                            Sounds like ASUS.

                            I tested parallel mode on an ASUS X99 Deluxe (latest 3101) as well as ASUS X99-A USB 3.1 (latest 3101) and they also freeze early on in the pass every time.

                            So, it sounds like every ASUS X99 motherboard also has this very annoying and easy to reproduce problem. Hope ASUS fixes it at some point as my 128GBs of RAM takes 49 hours per pass.


                            David, can you provide the 2603 and 9001 files, or do a diff on them to see if this is something we can fix ourselves with UEFI Tools or the like?

                            I'll file a tech support case with ASUS for my boards and cross my fingers.

                            edit: tech case started.
                            Last edited by Cyra; 06-28-2016, 05:35 PM.

                            Comment


                            • #15
                              A request has been made to ASUS to make the fix available across their range of boards. We don't know the status (but it was several weeks ago now that the request was made), or if any action will be taken.

                              We only had updated firmware for 1 board, the M5A97 R2.0. And we aren't sure if we are allowed to distribute it.

                              Comment

                              Working...
                              X