PassMark Software


No announcement yet.

Reclaim disk space after imaging with imageUSB

  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    Originally posted by Richard (PassMark) View Post
    I did some quick testing on a Windows 7 and a Windows 8 machine. On Windows 7, after Zeroing the USB drive was visible in "Computer"->"Devices with Removable Storage(5)" will show up regardless if I eject or yank the drive out.

    In Windows 8. The drive after zeroing does not show up in the list of drives in "Computer". It does show up in Disk Management, however, sometimes even in disk management it will not allow me to format the drive reporting an error, "Cannot find the file specified". If you run into this case, what I found to work was to use diskpart. I have enclosed the instructions below to reclaim the drive if you run into this problem.


    1. Start a Command Prompt with Admin Permissions. (Start, Type "cmd", right click on command prompt in the list of programs, and select "Run as Administrator")
    2. Enter the command "diskpart"
    3. Enter the command "list disk", locate the disk number for your USB Drive
    4. Enter the command "select disk X", where X is the number of your disk from step 3.
    5. Enter the command "clean", this will remove any and all partition or volume formatting from the disk with focus.
    6. Done, type "exit" to quit diskpart.
    7. Now in back in Disk Management, you should be able to right click the drive and choose new simple volume and proceed with formatting.

    We will investigate the issue further imageUSB and Windows 8 and see if we cannot provide a better solution.
    in case your USB drive were not listed in DISKPART when you type list disk, use:
    "list volume",
    select your volume,
    "select volume x"
    continue with step 5


    • #17
      Imaging Failed Message and CD drive remaining on my USB

      When I used the Zero UFD option, the program displays two drives for the same USB stick. One registers as USB,CDFS and the other as USB,Unkown. I checked the box for both drives, but once I run the Zero UFD, it says Imaging Failed and the usb shows two partitions still, one as a CD drive. Shouldn't the zero UFD function have cleared this?


      • #18

        Your drive must be one of the special "U3" flash drives. Details are here,

        A U3 flash drive presents itself to the host system as a USB hub with a CD drive and standard USB mass storage device attached.

        • This configuration causes Windows disk management to show two drives:
          • A read-only ISO 9660 volume on an emulated CD-ROM drive with an autorun configuration to execute the U3 LaunchPad, and;
          • A standard flash drive (FAT formatted) that includes a hidden "SYSTEM" folder with installed applications.


        While I haven't experimented with these type of flash drives myself, it could well be the case that the emulated CD-ROM part is read-only and can never be overwritten, wiped or reformatted.


        • #19

          Thank you for the reply. You are correct, it is a U3 drive. The Zero UFD option did work on the non CD partition, so it would seem it worked properly. Thank you for the helpful info!


          • #20
            2018Jan14. I insert my UFB (actually, a micoSD card in a USB adapter), but imageUSB doesn't see it. Now what?
            2018Jan16. After reviewing other comments, I found a computer with a U3 port (a buddy's laptop). I inserted the USB adapter with my 32GB microSD into his U3 port (blue) and imageUSB saw it; yay! Therefore I was able to use Zero UFD, then Win10 Disk Management saw it, and I was able to format it. I inserted it into my own computer, and it is working again; whew!
            Last edited by Mdj19; 01-16-2018, 07:54 PM. Reason: Experimenting while waiting for a response...