PassMark Software

Announcement

Collapse
No announcement yet.

memtest86 bootable USB not loading, blinking cursor

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • memtest86 bootable USB not loading, blinking cursor

    • Motherboard model number: M4A89GTD-PRO/USB3 (refer to CPU-Z screenshot)
    • BIOS version: 3030 (refer to CPU-Z screenshot)
    • CPU: AMD FX-8150
    • Summary of the issue you are experiencing: I have a bootable USB of MemTest86 V8.1 (Build 1000) that gets stuck on a blinking cursor on a black screen. I tried adding "M4A89",ALL,PARTIAL,RESTRICT_MP to the blacklist.cfg but it didnt work. The same bootable USB works fine on Asrock X399 Taichi (AMD Ryzen Threadripper 2950X), Asrock Z370 Taichi (Intel Core i7-8700k), MSI Z77A-G45 (Intel Core i5-3550) and ASUS ROG MAXIMUS XI APEX (Intel Core i9-9900k).
    Click image for larger version

Name:	lpnv3fh.png
Views:	38
Size:	21.7 KB
ID:	44552

  • #2
    This looks like a fairly old motherboard.

    Does it support UEFI BIOS? I had a look at the specifications for the board on the ASUS web site and it doesn't mention UEFI.

    V8 of MemTest86 will only work on machines with UEFI BIOS.

    On older machines you need to use V4 of the software.

    Comment


    • #3
      The font at the very beginning of POST looks close to UEFI / GOP, but the screen shortly after has that standard font that I associate with pre-UEFI BIOS. So looks like I'll need to fall back to V4.Click image for larger version

Name:	hMf5fAe.png
Views:	31
Size:	183.2 KB
ID:	44555

      Comment


      • #4
        Motherboard seems to be from 2010, but even then UEFI was reasonably common, the V2 UEFI standard was released in 2007. So maybe this model was late in getting an update.

        Comment


        • #5
          Possible. Anyways, v4.3.7 of memtest86 (contained on memtest 7.5.1001 ISO) is working OK. I managed to figure out how to automatically select only test #7 to loop through, but I can't seem to figure out how to run the CPU in parallel mode instead of only single core. I tried cpumask=0xffffffff in syslinux.cfg; the resulting the screen reports
          Code:
          CPUs_Found:   8    CPU_Mask: ffffffff
          CPUs_Started: 8    CPUs_Active:     1
          I can manually change to "parallel" mode and CPUs_Active changes to 8. Can I get v4.3.7 to start in parallel mode automatically? Thank you.

          Comment


          • #6
            There wasn't much in the way of automatic configuration options in V4. (to be honest it has been so long since we looked at V4, I have forgotten what the options were, but it is open source, so you can poke around the source code to figure it out).

            In V8 you can edit the configuration file (mt86.cfg) to set the CPU selection.
            CPUSEL=PARALLEL

            Comment

            Working...
            X