PassMark Software

Announcement

Collapse
No announcement yet.

MemTest86 Saving results to file - Unable to open file for writing on Mac

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • MemTest86 Saving results to file - Unable to open file for writing on Mac

    I run memtest86 from a USB flash drive. Whenever I want to save test results, for example a graph BMP or HTML, I get "Unable to open file for writing."
    The settings just let me select a language, not a file path to use or anything like that.

    How can I save my results?

  • #2
    Which version of MemTest86 are you using?
    Which edition of Memtest86 are you using?

    Note: You can't save the results to disk in the Free Edition.

    Comment


    • #3
      Hi David,
      I use V7.5 Pro

      Comment


      • #4
        Are you booting from DVD or USB?
        If USB, does the drive have a write protect function and does it have free space?

        Comment


        • #5
          From USB, has about 50MB free and no write protection

          Comment


          • #6
            Are you using the package as we delivered it. Some people repackage it into things like GRUB. Which might result in folder names being different.

            Can you send a photo of what you are seeing.
            (we can't think of any more obvious reasons why it can't write to a USB drive, so maybe we'll spot something amiss in the screen shot)

            Comment


            • #7
              I can't figure out the instructions provided with the package (using terminal to identify the drive and restore the image). Tried a few times and it failed, I hate CLI. So I ended up simply cloning the supplied .img to the USB drive. (I use a Mac) It boots, test runs but can't save data.

              Perhaps you could tell me what the right formatting for the flash drive is? As that is also not mentioned in the readme instructions.

              The partition for memtest is formatted as MS-DOS (FAT16), the drive is GUID Partition Map. Should it be MBR instead?

              Thank you

              Comment


              • #8
                You shouldn't need to worry about partitions, or file system selection. All this gets written to the USB drive as part of the image that we make.

                So I ended up simply cloning the supplied .img to the USB drive. (I use a Mac)
                How was this done on a Mac without using the command line?

                Comment


                • #9
                  Carbon Copy Cloner

                  Comment


                  • #10
                    We haven't used Carbon Copy Cloner, but if it works, then it should work.. probably.

                    Can you send / post a photo of the error you are seeing.

                    Comment


                    • #11

                      Comment


                      • #12
                        Can you see if the debug log was written to the USB drive.

                        The log file (MemTest86.log) is automatically created and updated while MemTest86 is running. This file is saved in the 'EFI/BOOT' directory in the USB drive's first partition.

                        If you do have it can you EMail it, or attach it to a post.

                        Comment


                        • #13
                          Here it is, hope it contains something useful!
                          Attached Files

                          Comment


                          • #14
                            Well that was an interesting log file. Something is definitely messed up with that drive. For example the log reports there are 3 partitions on the drive and there should only be 2. And the EFI\BOOT directory isn't where it normally is.

                            So very likely the cloning process that you used, didn't do the right thing. Or at least not what MemTest86 was expecting.

                            Instead can you follow the procedure we suggested and see if that works.

                            The process for the Mac is:

                            Get the download, which is memtest86-pro-usb.tar.gz in the case of the Paid for software. Then uncompress it to get the memtest86-pro-usb.img file.

                            1) Insert a USB drive into a USB slot.

                            2) Determine which device the USB drive is assigned as by opening the Terminal and typing the following command:

                            diskutil list

                            3) Unmount all volumes on the USB drive by typing the following command:

                            diskutil unmountDisk [device name]

                            4) As root, use the 'dd' command to write the image to the USB drive. For example,

                            sudo dd if=$USB_GPT_FREE_FILE.img of=<dev>

                            where <dev> is the device the USB key is assigned to. Use the base device (ie. /dev/disk1) not a partition designation (ie. /dev/disk1s1).

                            Warning: all data on the USB key will be lost.
                            Warning Warning: Make sure that the device used in the dd command above is correct !!! This is super critically important.

                            Or if you have a Windows machine, the process is much easier, use the included ImageUSB software in the memtest86-pro-usb.zip package.

                            Comment


                            • #15
                              I didn't know I had to type "/dev/" in front of the device name. It now transfers data but the resulting partition of the USB drive becomes unreadable to macOS.

                              Also "Use the base device (ie. /dev/disk1) not a partition designation (ie. /dev/disk1s1)." is this a suggestion or a must? My USB drive has several partitions on it, one of them is memtest.

                              Comment

                              Working...
                              X