PassMark Software

Announcement

Collapse
No announcement yet.

Memtest86 shows error, but Corsair refuses to RMA

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Memtest86 shows error, but Corsair refuses to RMA

    Good day everyone. I'm stuck in an unclear situation, but I will tell the story from the very beginning.

    One day (in August 2017) I decide to check my CPU (just in case) and launched LinX. His results contained no errors but were very strange - the residual numbers did not match in the column (all test were with equal parameters). Then I tried Prime95 with the same memory consumption and got an error. Finally with memtest86 I found culprit in specific RAM-module (it contained only 1 error). I contacted Corsair's support and replaced the faulty bundle of RAM.

    But sadly, story does not end on that =(
    When new bundle arrived I immediately tested it with memtest86 and... found an error (with different address this time). I again contacted Corsair's support, but this time they refuse to RMA cause, I quote:

    Memtests are to confirm issues are related to memory if there's problems with the sytem. If there are no problems with the system, then it doesn't matter if you have errors in the third party memtest since that doesn't mean the memory is faulty.
    and

    If you have no issues in everyday system use and only during synthetic testing to find errors then that's the difference between functionality and executable.

    You use memtest to confirm you have an issue with memory, not run memtest to find an algorithmic error for no reason.
    Is the Corsair's right or not?

    I just want to build rock solid stable system and no more...

    ps
    Sorry for not very good English.

  • #2
    There are various reasons for RAM errors. Having two sets of bad RAM is unlikely. So maybe the fault is elsewhere.
    Seeing the actual test results might help in guessing at what is wrong.

    Comment


    • #3
      I have two sets 2x8Gb

      https://mega.nz/#!t80gWRDQ!VYYlzkPeH...e0NufXhY-15uww -this one with all modules

      https://mega.nz/#!Nt0DjK7C!YQ7h0SgWJ...LCu42httz8EB9c -and this one with only new modules

      I testing many times and address were always the same (within the number of installed modules).

      Comment


      • #4
        It does look like a RAM error.
        But if you suspect the new modules are bad it is hardly surprising that both the test scenarios you picked fail in a similar manner, as they both contain the bad module.

        Do you have the report from just the original modules?

        Comment


        • #5
          Unfortunately no. Previous RAM-bundle I tested with old memtest86 (to be as accurate as possible - memtest86+). But I copied error on paper:
          Test#6, Pass#0, Failing Address - 00527efb8a8-21118.6MB, Good - ffa80000, Bad - ff880000, Err-Bits - 00200000, Count - 1, CPU#0
          This was the first time that an error occurred and later all errors had the same address until I switched order or number of modules.

          Comment


          • #6
            Originally posted by David (PassMark) View Post
            Do you have the report from just the original modules?
            or... Wait... I don't understand what you mean >_<
            Original modules - previous modules or testing one by one modules?

            Comment


            • #7
              So all the reports look like RAM errors. But it isn't impossible that there is some other cause.
              Maybe you can make 1 good set from the two bad sets.

              Comment


              • #8

                Maybe... If I had 2 bad sets.
                I have one good set and one not good set. Total 3 out of 4 good modules.

                Comment


                • #9
                  Originally posted by David (PassMark) View Post
                  But it isn't impossible that there is some other cause.
                  Do you have some ideas? Then I will say what I did or not did. I'll give you any information.

                  Comment


                  • #10
                    Quick solution is to borrow known good RAM from someone else to test on your system.

                    Comment


                    • #11
                      Okay, I have some other sticks, I'll write after the tests.

                      Comment


                      • #12
                        https://mega.nz/#!49tRjbKC!J6sjmKswY...HUh-eX_jFlan64 - Results with known good RAM

                        But before I did this, I tested faulty memory once again and... lol! Number of errors increased! May it be a RAM degradation?
                        https://mega.nz/#!98lzQbxT!1xCiHVGLg...PwXZ4evWDKnsPU



                        btw
                        I found a little bug in program. For example, when you input a number of tests - key may do a double tap. Or another example, when you ending test and press a key - can also occur a double tap and you can accidentally skip a report saving.
                        This occur only on my desktop, I tried various configuration what includes a different GPUs, keyboards, external devices and BIOS settings - but nothing helped to avoid this double tap bug =(
                        On my laptop everything work fine.
                        Then I decided that this can be a compatibility issue between MOBO and memtest.
                        (sometimes I think I worry too much about small things...)

                        Comment


                        • #13
                          So the known good ram had no errors. This would imply the CPU, motherboard and BIOS are OK and make it more likely the your 2nd set of RAM is in fact bad. Maybe you're just unlucky.

                          Comment


                          • #14
                            What should I do now? Try to catch error in OS for Corsair?

                            Comment

                            Working...
                            X