PassMark Software


No announcement yet.

Memtest86 USB boot 7.4 boots with V4 instead with UEFI and Legacy enabled

  • Filter
  • Time
  • Show
Clear All
new posts

  • Memtest86 USB boot 7.4 boots with V4 instead with UEFI and Legacy enabled

    Hi, I need to run a memory test to send it to Corsair so they can replace my memory cards (set of 4X4GB). I installed the USB V7.4 and booted from it a few times but it keeps running V4.3 instead.

    In the BIOS :
    - boot order I see my #1, my CD rom, #2, Windows boot manager, #3 my 2nd HD, #4 UEFI: USB USB hard drive, #4 UEFI: USV USB Hard drive
    - Legacy USB Support = Enabled
    - Boot Mode Selection = UEFI and Legacy
    - Storage Boot Option Control = Legacy only (tried Legacy first and UEFI only)

    Motherboard = Gigabyte Z77MX-D3H
    BIOS = F15
    my USB is an OCZ Raly2 1100, 7.4GB

    I am running out of ideas.

    - should I just stick with 4.3 (or 5.1) and run my memory test ?

    Whatever Memtest version i run, I need to know :
    - what test should I run for Corsair to accept it
    - for how long (or it will stop automatically ?)
    - how to I transfer the result into a file ?

  • #2
    This page might help with UEFI booting

    We don't know what Corsair will accept.
    V7 of MemTest86 stops automatically after 4 passes of all tests & has a option to write a report, or you can just take a photo of the screen.


    • #3
      I already answered to what your link says to check. I was able to run Memtest86 V5.01 from the USB.
      1. You have an older system that does not support UEFI
      BIOS says it is Legacy and UEFI
      Windows Disk manager shows my drives as being UEFI
      1. Your system supports UEFI but is configured in legacy mode (ie. BIOS)
      Boot Mode Selection = UEFI and Legacy

      In any case, weather V7 or V4, I do not care. All I want is a report showing memory errors that I can send to Corsair.

      I ran V4 for about 30 and hit Exit. I wanted to see where the report is. I checked the USB /EFI/BOOT but found no reports there and Benchmark folder is empty. I used your USB setup that I downloaded for your site today (for V7). However, I just found how that the Boot and Benchmark folders are read only. So that seams to be reason why no report was saved. However, why would those folders be read only ? they were created that way from your own USB image. I did not change anything on the USB once I ran your image setup.

      I will remove the read only and try it again tonight to see if at least the report gets saved or not on hitting Exit.


      • #4
        We don't have a Gigabyte Z77MX-D3H available to test with, so it s hard to tell you exactly what boot settings are required.

        V4 of of the software didn't write a report to disk (in fact had no functionality to even access a disk). V4 is pretty old now.