PassMark Software


No announcement yet.

Inconsistent results between UEFI 7.4 and the bual boot BIOS 4.3.7 Test 10

  • Filter
  • Time
  • Show
Clear All
new posts

  • Inconsistent results between UEFI 7.4 and the bual boot BIOS 4.3.7 Test 10

    On an Intel S400SC motherboard, with BIOS 4.3.7, I get a clean bill of health on both 8GB Hynix ECC registered RAM and 16GB Samsung ECC registered RAM. But with UEFI 7.4 I get massive errors on the 1 8GB stick, and 4 independently tested 16GB sticks under Test 10. I also notice that the Test 10 is much quicker, with almost unnoticeable pauses under BIOS 4.3.7, but major sleep pauses of 5 minutes nuder UEFI. The error count for each 16GB stick is exactly 1024 for 1 pass.

  • #2
    I couldn't find any information about the Intel S400SC motherboard. Maybe you got the model number wrong.

    If you get a block a errors, always at the same fixed memory address range, then maybe there is a UEFI BIOS bug on the motherboard. Sometimes the BIOS claims that a block of RAM is free and available for use, when in fact it is also in use by some memory mapped hardware. So you have MemTest86 and some other hardware writing to the block at the same time, causing memory corruption. If it was real memory corruption, then you should also see ECC warnings, and I assume you don't (assuming whatever CPU you are using supports ECC RAM).


    • #3
      Thanks for your reply

      Sorry, my bad typing. It is S2400SC. I do not see any ECC warnings, but there is a beep code which I cannot decipher on boot. Also, I do not know where to look for ECC warnings. The cpu is Intel E5-2450L (supports ECC RAM), and only 1 cpu is installed on the MB. I ran the tests using 1 core. I ran it again with 64GB installed (4 x 16GB), and again got a result showing 1024 errors in Test 10 only. The summary report shows
      Lowest Error Address: 0x3FFFE018 (1023MB)
      Highest Error Address: 0x3FFFF814 (1023 MB)
      Bits in Error Mask: 00000000FFFFFFFF
      Bits in Error - Total: 32 Min: 0 Max: 32
      Max Contiguous Errors: 2

      As I am new to the forum, is there a guide or tutorial on site navigation - e.g. how to search the forum, how to take a screen shot?
      Poking around, I did see a couple of posts on S2600CP which is a later, similar MB where it looked like it might be a UEFI bug. There it seemed like changing the BIOS setting for Optimized UEFI, fixed it for some people, but I still see the same errors. You had suggested that a work around might be to remove 1GB of RAM space from the test, so that it is free for other use. How do I do that? I am afraid addresses are a foreign language to me. The errors I see usually start after the 3rd pause, at 75%, so I want to remove 1GB from the beginning.


      • #4
        You can search the forum using the Search Box (top right of the web page).
        You can take a screen shot in Windows using the Print Screen key on your keyboard.

        I assume you are referring to this other post
        there is also this external post, also concluding the MB BIOS is bad.
        And in that case it was very definitely a BIOS bug. Given you have a similar motherboard, identical errors at identical address and no ECC warning it seems extremely likely that you have a similar BIOS bug.

        You could try contacting Intel and ask them to fix it.