PassMark Software


No announcement yet.

Memtest86 Only Using Two of Four CPUs (actually threads)

  • Filter
  • Time
  • Show
Clear All
new posts

  • Memtest86 Only Using Two of Four CPUs (actually threads)

    I recently tried the free version of Memtest86+ and wanted to test with all available CPU threads. The program says I have 4 CPUs detected, but puts two of them in a D state, which I assume means disabled. How do I enable all four of them? The configuration is set for Parallel (All CPUs), but just above that on the configuration screen, it says "List of CPUs available for testing: 0 2". Please advise.

  • #2
    MemTest86+ is not our software. We develop and support the original MemTest86 software. Even though they are using our name, which is rather confusing. Please see their forum for support.


    • #3
      I meant to say MemTest86, without the plus! Sorry about that. I tried to correct my title of the post, but the system would not allow me to do so. So please reply in reference to the same problem as described, but with MemTest86. Please correct the title if possible, or should I start a new thread with the correct name in the title?


      • #4
        It is likely that your system's UEFI firmware (BIOS) does not have proper multiprocessor support, so MemTest86 is only able to use what CPUs are available/supported. We can verify this by having a look at the MemTest86.log that is stored under EFI\BOOT. You can upload or e-mail it to us.

        Also check for the latest BIOS update from your motherboard vendor.