PassMark Software


No announcement yet.

computer froze running memtest86

  • Filter
  • Time
  • Show
Clear All
new posts

  • computer froze running memtest86

    I was running memtest 86 V7.4 from a USB stick, when it froze at the 50% mark during the 4th pass - up until that point it showed zero errors
    - my system spec,
    Intel i7 5960X
    Asrock Fatal1ty X99 Professional
    Corsair Vengance 64 GB (8 sticks, 8 GB)
    Sam 950 PRO 512 GB
    Sam 950 Pro 256 GB
    850 EVO 256 GB X2
    LG 27UD68-P 4k Monitor
    ZOTAC GTX1070
    Seasonic SSR-550RM PSU

    reading other threads with similiar issues, i see different procedures recommended, but the one common check is to run memtest with one stick at a time.
    Given i've got 8 sticks to test, and the 3.5 passes yesterday took 9+ hours, do i really need to run all 4 passes? That question may sound foolish, but i use this computer for work, running memtest on 8 sticks indiviually is going to take this computer offline for an inordinate amount of time

    Any suggestions?
    Thanks in advance

  • #2
    One or two passes are normally enough to have a fair degree of certainty.

    If the whole system froze then it might or might not be a RAM error.

    Are you seeing any bad behaviour outside of MemTest86? (e.g. BSOD in Windows).

    Rather than testing 1 stick at a time it would make sense to test 4 sticks at a time, in two groups.


    • #3
      WELL, yes, got my first BSOD today after posting. I called into Asrock tech support, got hold of a pretty decent rep, and he indicated they were aware of some boards BIOS having a bug causing the memtest freeze issue. He walked me thru my settings and had me change one setting, increasing frequency to 2800 from where i'd set it at 2600 (my cpu shows it supports up to 2133 so i thought i'd stretched it's limitations a bit. After the increase, an hour or so later got the BSOD with some indication about a memory conflict. I dropped freq back down to 2400 and still had another BSOD screen.

      He also pointed me to the Windows Memory Diagnostic tool so i ran it and memory showed fine. I've got a feeling it's my memory sticks "not playing" nice. When i first built the system i bought 4 sticks, 8GB each of corsair ram, that were on the QVL list. I installed them in all the "1" slots, ie A1, B1, etc. Then later i added another set of the same model sticks, 4 sticks 8 GB each, and installed them in the "2" slots.

      I did eliminate the CPU from the equation, running intel's Processor Diagnostic Tool - it passed fine. And the PSU i assume, key word there is assume, should be fine - it never hit above 220watts when the BSOD hit - (cyberpower has a wattage gadget that monitors it for me.

      I'm thinking tomorrow to yank the 2nd set of sticks and try it with just 4 sticks in the "1" slots hoping the issue is the one of the two sets of sticks not matching as well as they should have or if a spike damaged one or both sets (see next para). But it was damn hard to find a 64 GB set that was listed on the QVL, and with pricing of memory today being nearly twice what i paid 2 years ago, i'm not investing in a new set.

      I'm actually wondering if a power spike caused all this - system was incredibly stable for nearly two years, then about 2 months ago had the power flicker while i was in the other room using a different computer, and i found the subject computer shut down where it'd been asleep, Then i noticed where temps on the same task that used to run 65-68C, were now in the 75-78C range (98-100% load), then strange things started to happen where i lost or windows explorer corrupted to the point of the computer being incredibly slow and unusable. That's when i tried the "one stick of ram" trick and it seemed to clear all the issues, but they slowly came back to the same level of unusability - i'd open "my computer" and none of the drive icons would be there, etc

      I've since added a decent UPS (sinewave model CyberPower) to that computer i suspect a voltage spike damaged the mobo or ram. I'm hoping it runs with just the 4 sticks, but it tempts me to upgrade this computer to a newer gen cpu & mobo. I'd like to get it to make it long enough that ram prices come back down - the same sticks i purch'd for $222 /32 GB are now $404. And i thought bitcoins had gone crazy

      anyway, thanks for looking in & responding
      Last edited by The Orig Ralph; 01-10-2018, 02:52 PM.


      • #4
        Originally posted by The Orig Ralph View Post
        I called into Asrock tech support, got hold of a pretty decent rep, and he indicated they were aware of some boards BIOS having a bug causing the memtest freeze issue
        Likely he is operating with half the knowledge & referring to this known UEFI multithreading bug ASRock have in some boards. That UEFI bug happens much sooner than 4 passes however. So I don't think it is that issue. Maybe he knows something we don't however.

        ...and had me change one setting, increasing frequency to 2800 from where i'd set it at 2600
        Doesn't make sense to me. You have suspected stability problems, so the solution is to run the RAM even faster???

        The trick with all these problems is to first make sure the problem is reproducible, and reproducible quickly. If you can't reproduce it, your never going to be sure if a particular change fixed the problem or not.


        • #5
          "and had me change one setting, increasing frequency to 2800 from where i'd set it at 2600" - yeah, i wondered about that myself, but during our conversation, out of curiosity i had asked him how long he'd been doing this ie computer diagnostics, and he indicated since 1993, so i assumed he knew what he was doing. But he recommended while he was looking at the corsair's specs (it's OC freq is 2800)

          last nite i pulled 4 sticks out, all the "2" slot sticks, set the remaining sticks at 2400 and ran one memtest86 for 2 passes, zero errors. Tonite i'll test the other 4 sticks, If i don't get any errors, i'm going to run this rig for awhile with only 4 sticks and see if the OS corrupts again.

          What keeps nagging, at the back of my mind, is that this problem didn't start until the system shut down when the power flickered. And like i said above, i noticed my temps had increased some - i keep a widget from RealTemp that displays temps down in the corner of my desktop. Running the same tasks, ie rendering video files, with cpu showing near 100% load, temps are now about 10C higher. I've recalibrated RealTemp sensors, and compared it's readings to HWMonitor's and they're close, so i'm comfortable the temp readings are accurate.

          I forgot to mention earlier, my board has "Dr Debug" - and the values it would display (iirc, 19 and 60), when i looked them up, they were both "memory related".

          I'm going to see what the other 4 sticks show tonite, and if they do not show any errors, i'll run this rig on 4 sticks and see if the OS corrupts again. The last two times it took about 10-14 days for it to show up. If it stays stabile with 4 sticks, then i'll assume it was incompatibility between the two sets. The temp thing will continue to bother me, and the fact that the 8 sticks ran fine for nearly 2 years will also be a little worrisome,

          again, thanks
          Last edited by The Orig Ralph; 01-10-2018, 09:16 PM.


          • #6
            think i'm zeroing in on the cause of the issue. Not sure if this comes under your expertise but i remembered when i had run passmark memtest86, i had noticed it was reporting the clock frequency of the ram as 2999 and 2998 (depending on the page. My Corsair ram's native speed is 2133 and OC's to 2800

            the XMP Profile 2 (a default profile in my mobo's BIOS, is clk freq of 3000, and even though i've set the clk freq at 2400, it's apparently running the XMP Profile 2 even though i haven't selected it

            is it a physical controller that selects clk frequency or firmware coding?

            and fyi, before taking these shots, i cleared CMOS, then reflashed the latest BIOS

            1st, shot of BIOS main page showing the 2400 freq it's reporting

            2nd, the memtest86 page while testing

            XMP Profile 2 should not be running at all as it isn't selected, "AUTO" is selected by default, and there's no way to un-select or dis-able

            any thoughts??
            Last edited by The Orig Ralph; 01-10-2018, 10:58 PM.


            • #7
              MemTest86 doesn't report on the memory speed currently selected. What it reports on is what the RAM claims to support (i.e the max speed that appears in the RAM's SPD data). RAM SPD data never changes, regardless of BIOS settings.


              • #8
                well, that theory bit the dust - what you're saying is Corsair used ram chip or modules good up thru 3000 in my 2800 sticks - is that correct?


                • #9
                  what you're saying is Corsair used ram chip or modules good up thru 3000 in my 2800 sticks - is that correct?
                  Any data can be programmed into the SPD data. One would hope the data accurately reflected the capability of the RAM. The BIOS then decides what speed to run the RAM at, based on the CPU installed, the RAM's capability and whatever is programmed into the BIOS firmware in terms of how aggressive to be. SPD should be accurate, but we have seen instances were it isn't, especially for fields like manufacture date.

                  You can dump all the SPD data using RAMMon.


                  • #10
                    thanks - it's been stable all day so i'm going to let it run with 4 sticks at 2400 and see what happens
                    appreciate the assist