PassMark Software


No announcement yet.

Consistent freezes during test #7 and #9 - need help to diagnose.

  • Filter
  • Time
  • Show
Clear All
new posts

  • Consistent freezes during test #7 and #9 - need help to diagnose.


    I have the following system, which i assembled for home NAS.

    SuperMicro X10SLM motherboard
    Pentium G3258 processor
    2x 8 Gb Crucial ECC RAM

    The problem i have is consistent freezes of MemTest, usually on tests #7 and #9. This happens even in DOS version with RounRobin CPU selection. Usually this happens during first pass, but twice it froze on second pass. Tried the following

    1) Run with just one RAM module - no difference
    2) Put one RAM module into different slot - no difference

    At this point i start to suspect that the issue is with CPU (as memory controller is embedded). Any way i can verify this without finding another CPU ?

  • #2
    Also, here is log file from UEFI version, which seems to freeze much faster than DOS version.
    Attached Files


    • #3
      Log seems to show it locked up in test #5 (so it is random if you also saw it freeze in #7 and #9).
      But there were no memory errors in the log, ECC RAM also didn't report any memory errors.

      So I don't think you are going to get a conclusive answer from the log as to what is the cause of the freeze. Unless you have some high end test equipment. It is going to involve some trial and error. Start by checking for available BIOS firmware upgrades and temperatures. Then move on to swapping PSU, CPU, MB, GPU until it works.


      • #4
        Well, it's a server MB, the latest BIOS was released almost 2 years ago and without it i couldn't even boot the system, as stock BIOS doesn't support Haswell refresh. Anyway, i've tried something different today - changed CPU selection to CPU #1, instead #0. Guess what ? All tests passed. This looks like 99.8% CPU issue, but is there any chance it's a bug in MemTest ?


        • #5
          There aren't any MemTest86 bugs we are aware of at the moment.

          But some UEFI BIOSs have firmware bugs that stop multithreading working correctly. See,

          (but this was only a UEFI bug. It doesn't effect old traditional BIOS. And you said you saw the same problem in the old BIOS release, so it would seem to rule out UEFI as the cause)