PassMark Software


No announcement yet.

MEMTEST86 and (maybe) weird results depending on BIOS configuration.

  • Filter
  • Time
  • Show
Clear All
new posts

  • MEMTEST86 and (maybe) weird results depending on BIOS configuration.

    Hi. I built a new system around a Gigabyte X99 Ultra Gaming with a 5820K CPU and 64GB 2400 C14 Memory Kit that is in the QVL (supported/tested list) of the motherboard.

    I tested the system with Memtest86 v7.2 Free and got these (weird) results:
    (read carefully to understand)

    CPU clock / Memory Clock / Errors
    3300 / 2400 (1,20V XMP1) / more than 100 (stopped in test #3)
    3300 / 2133 (1.20V) / 24 (8 errors in #4 16 errors #5, stopped afterwards)
    3300 / 2666 (1,35V XMP2) / more than 100 (stopped in test #1)

    4000 / 2133 / 0 errors in all 13 tests (1 pass after 3h 15m)
    and again with v7.3 Free

    4000 / 2133 / 0 errors in all 33 tests (2,5 pass after 13h)

    • Without overclocking my CPU and only using the XMP1 (the official 2400Mhz memory speed) I got many errors and I stopped the test after a few minutes.
    • I lowered the memory to 2133 (below the official 2400) and seemed OK initially but Test 4 (out of 13) had some errors and even more in Test 5, and I stopped the test after that. So better but still some errors.
    • Still without overclocking my CPU and I used XMP2 (2666) but lots of errors like XMP1.
    • I overclocked the CPU to 4000 (from 3300 by using the "Performance" setting of the Easy mode of BIOS) and the standard 2133 in the memory (No XMP) and after 3 hours ALL the 13 tests (first time run v7.2 Free) and after 13 hours (second time run v7.3 Free) were WITHOUT ANY ERRORS.

    Does this make any sense?

    P.S. You can add my motherboard to the List of Motherboards with issues when running MemTest86 in multi-CPU selection modes.
    I only used Core 0.

  • #2
    For memory there are more settings than just the clockspeed. Maybe some of the timings or voltages were also changed as you changed the CPU clock speed?

    You might want to test with just half the sticks installed to find the bad one.

    What BIOS version are you using in the motherboard?


    • #3
      Hi David
      I'm using the F4 that came with the board. I know about F5 and F6 (beta) that (supposedly?) improve memory compatibility but I'm reluctant to flash them for now.
      That was my guess too. Something with the voltages. I'm using the easy mode that only has 3 settings for the CPU green/normal/performance.
      Normal gives errors with or without XMP, Performance without XMP (haven't tried with XMP) has no errors at all.

      But....Are you saying I have a bad memory stick?
      After the 2,5 passes of V.7.3 (which by the way the 2nd pass was far more slow than the first one) and 13 hours without errors I was confident that all 8 sticks of my memory is OK.


      • #4
        Are you saying I have a bad memory stick?
        As it doesn't work in the stock configuration, then yes, it is probably bad (or at least marginal).


        • #5
          Hmmm. Now you got me worried.
          I read though, many cases in other forums where people tested one-by-one sticks and slots and didn't find any problems. Yet the whole kit produced some errors.
          I don't have the stamina to test it like that.

          Anyway, since that particular BIOS settings worked without errors for so long, I'm not planning to touch any of the settings for now (not even to disable the pointless for me motherboard LEDs). I won't even try to enter the BIOS!
          Thanks for all your help.

          P.S. I wish Memtest86 could work with all cores so I wouldn't have to wait for so long to test each configuration. Imagine testing 8 sticks x 8 slots x different bios settings. It could take a whole month.


          • #6
            Originally posted by David1996 View Post
            I wish Memtest86 could work with all cores
            It does on most motherboards.
            Some have a UEFI bios bug however, which prevents it.