PassMark Software


No announcement yet.

DDR4 error in v4.3.7, but no errors in v7.2

  • Filter
  • Time
  • Show
Clear All
new posts

  • DDR4 error in v4.3.7, but no errors in v7.2


    I have a few questions regarding results I've received.
    I recently built a new PC, and I'm currently testing the RAM.

    My build is:
    Mobo: Asus X99 A-II
    Cpu: I7 6850K @4k
    Ram: Corsair "CMK32GX4M4B3200C16W" XMP @3200Mhz
    Went through a few Prime 95, Intelburn and RealBench stress tests with no issue (cpu package maximum 78c)

    After creating a usb boot of version 7.2, I accidentally loaded the older version 4.3.7 (I had UEFI and legacy options in the boot menu).
    After an hour and a half, the "Pass" and "test" reached 100%, but kept going like that for half an hour (I believe it was only on Test #7, for some reason).
    In test #8 ("Pass" is still showing 100%) I got "Error Confidence Value: 172":
    Lowest Error Address "002e6cb2748 - 118804.6mb
    Highest Error Address "002e6cb2748 - 118804.6mb
    Bits in Error Mask: 00000040.
    (Added a picture of the error)
    Later on, when it finished, the "Error Confidence Value" raised to 236 (addresses remained the same)

    I ran one pass of memtest86+ 5.01 - no errors.
    I read that DDR4 support was introduced in version 6 and above, so I ran version 7.2 (after choosing single cpu instead of parallel, because it seems there's an issue with Asus x99 boards).
    First test without turbo mode ran for 12.5 hours (4 passes), core #0 - no errors.
    Then I enabled XMP 3200Mhz and processor turbo @4k core #4 out of 12 threads (I chose core #4 because v4.3.7 failed on core #2 (it doesn't include threads, only 0-5)) , ran it for 9 hours (3 passes) - no errors.

    I'm planning on running at least 1-2 passes on each cpu core just in case, maybe even one 24 hours test)
    My question is - do you think the error was a result of compatibility\support issue or bug?
    Should I trust the new version and stick to its results, or run more tests?

    Last edited by Ido; 01-14-2017, 02:38 PM.

  • #2
    Your screen shot was too small to see the details.

    There might well be a real RAM errors.
    Maybe the memory address in question was blocked from testing by the UEFI memory map. Or the problem might only occur under higher load (beyond one CPU core).


    • #3

      Thanks for the quick reply.
      When I ran the test on v4.3.7, it only chose single core "cpu active 1", core #2 (and it reached 100% pass already in the middle of the tests.
      I ran v7.2 on 3 different cores separately already, and I didn't get any error in any test.
      When I ran the test on memtest86+ I also didn't get any error and I believe it didn't run under UEFI.
      I can't run a test on multiple cores because it gets stuck on test #2 (Asus x99 board).

      What do you suggest I should do in order to test it? Should I just contact Corsair and RMA?
      Should I trust the older, non DDR4 supported test? (or does it actually support ddr4 now?)

      I just chose to add a picture by pressing the camera icon>upload and chose the picture. The jpg resolution is fine before the upload.
      here's a link to the picture:


      • #4
        I wanted to update, as I ran more tests on v4.3.7.
        I've run a set of 4 passes on v4.3.7 - 1.5 of the tests was on "round robin" (I believe it's the name - it's the one that switches between cpu cores after every test) and 2.5 of the tests I switched to parallel.
        4 passed - 0 errors.
        I ran 2 more with parallel option - no errors.
        v4.3.7 is currently running while I'm at work, before I left it has already finished 2 passes on round robin - no errors.

        So that's over 15 hours of testing, of 8 passes.
        (The "pass" % was a lot more accurate on all the passes now... On the original failed run, it was already set on pass100% on the 6th test)
        I will edit this comment when I get back, hopefully it'll finish 2 more passes.
        If it does not fail within 24+ hours of testing on v4.3.7, is it safe to say my ram is ok?


        Update: So it finally finished a 3rd pass, it did a lot of iterations...: It took 17:42 hours, 3 passes - no errors.
        I can't seem to reproduce the error (or any error) after 22+ hours of testing on version 7.2 (about 13 passes), 24 hours+ on version 4.3.7 (about 9 passes) and memtest86+ (1 pass).
        I'm going to assume the kit is fine. If I get stability issues I'll retest in legacy+UEFI and apply for RMA.
        I'll be glad to hear your opinion on the matter.
        Thank you very much for your time and knowledge.
        Last edited by Ido; 01-16-2017, 05:05 PM.