PassMark Software

Announcement

Collapse
No announcement yet.

Problem with sleeper - PC goes to sleep and doesn't wake after last cycle completes

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Problem with sleeper - PC goes to sleep and doesn't wake after last cycle completes

    Hi,

    I am using sleeper through command line interface to enter sleep (S3) for 2 minutes and then exit for one cycle. This works and PC goes to sleep and exists successfully but then after a few minutes it goes to sleep again and doesn't wake until I press the power button. This is happening on windows 7 and also happened if I did a few cycles - after last cycle ends everything is OK but then it goes to sleep again and doesn't wake up. My PC is configured to never go to sleep.. This behavior is not always reproducible but it happens from time to time.

    This is my command:

    "C:\automation\sleeper\Sleeper.exe" -S0010 -R 120 -N 1 -P 5 -L "C:\automation\sleeper\sleeper_1388391424563.l og" -F -E

    One last comment - I am running the command remotely using psexec, meaning I am running:
    "C:\pstools\psExec.exe" \\my-remote-pc -d -accepteula "C:\automation\sleeper\Sleeper.exe" -S0010 -R 120 -N 1 -P 5 -L "C:\automation\sleeper\sleeper_1388391424563.l og" -F -E

    sleeper log:
    2013-Dec-30 10:17:04 ************************************************** ********************
    2013-Dec-30 10:17:04 Sleeper V2.3 (Build: 1009), built on Oct 15 2012 10:38:25
    2013-Dec-30 10:17:04 Option -R: Duration: 120.
    2013-Dec-30 10:17:04 Option -N: Num cycles: 1.
    2013-Dec-30 10:17:04 Option -P: Wait before 1st sleep: 5.
    2013-Dec-30 10:17:04 Option -L : Log file name: *C:\automation\sleeper\sleeper_1388391424563.log*.
    2013-Dec-30 10:17:04 Option -F: Forced sleep.
    2013-Dec-30 10:17:04 Option -E: Auto exit.
    2013-Dec-30 10:17:04 ************************************************** ********************
    2013-Dec-30 10:17:09 Going to sleep, S3, Unforced, Duration 120sec
    2013-Dec-30 10:19:19 Wake up from S3, Cycle 1
    2013-Dec-30 10:19:19 Sleep time OK 130sec
    2013-Dec-30 10:19:19 Successfully left sleep state S3...
    2013-Dec-30 10:19:19 Last cycle completed

    Thanks,
    Michal

  • #2
    It most likely the normal Vista / Win7 behavior.

    You can find some details about the issue here,
    http://www.passmark.com/forum/showth...er-it-finishes

    Comment

    Working...
    X