Announcement

Collapse
No announcement yet.

Sleeper set to 420 seconds S3 state, but wakes up before timer ends

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Sleeper set to 420 seconds S3 state, but wakes up before timer ends

    Hello everyone,

    i use the command line of sleeper.exe to send my computer into the S3 mode for 420 seconds. Unfortunatly the system sometimes wakes up before this and displays that the sleep time is too long! I would understand this, exept that it does sometimes work. Is there a time limit to the S3 state?

    Thanks

    TinyTim

  • David (PassMark)
    replied
    Opps, there was a typo in my previous post. Sorry. It should have read,
    "So your conclusions are probably correct"

    Leave a comment:


  • TinyTim
    replied
    It was worth a shot, but since we do use the same RTC as the rest it has to be one of the external devices. Once in S3 state only a signal going over the pci-e bus can wake it up. This would be LAN, WLAN, USB (mouse, keyboard etc.) ....

    Thanks

    Leave a comment:


  • David (PassMark)
    replied
    Sleep & hibernation often fail due to hardware and / or device drivers not doing the right thing. So your conclusions aren't probably correct about it being one of the PCI devices.

    Leave a comment:


  • TinyTim
    replied
    Well, i am getting closer to the source it seems. You guys basically programm the real time clock with the current time plus the "sleep time" in order to wake it up. Register 70 if i am not mistaken. We use the same real time clock chips as everyone else.

    All devices which hang on the pci express bus can wake up a system, which in my case also incl. audio, hadd, vga, wlan etc.... one of these devices overwrites the wake up timer in the RTC.

    Ill check some more, thanks guys!

    TT

    Leave a comment:


  • TinyTim
    replied
    This must be an issue with our BIOS's. I work for Fujitsu Siemens Computers and unfortunatly i get this error on about 70% of our systems. It works fine on an HP and Apple System. Strange indded!

    I will keep looking, thanks tough.

    TT

    Leave a comment:


  • Michael (Passmark)
    replied
    We tried this command on a Vista machine and Sleeper behaved as expected (didn't wake up too early or too late).

    Leave a comment:


  • TinyTim
    replied
    Hello,

    the command line that i use is the following:

    call sleeper.exe -S00100 -N 1 -F -R 320

    Thx

    Leave a comment:


  • David (PassMark)
    replied
    We don't believe there is any general problem with Vista. More likely the issue is specific hardware or incorrect usage of the tool.

    The command line you posted doesn't specify a duration, but you claim you are specifying a duration. If the command line you posted above isn't the one you actual use, can you post the one you actually use.

    Leave a comment:


  • TinyTim
    replied
    Yes, i specify the time also. The commands are correct, it does work on a small number of systems, occasianlly. There seems to be a wakeup call or a timer flag that runs out too quicky in vista.

    Leave a comment:


  • David (PassMark)
    replied
    Did you trying using the -R flag to specify the sleep duration?

    Leave a comment:


  • TinyTim
    replied
    Hi,

    the system supports S3 and S4. My command line is :

    call sleeper.exe -S00100 -N 1 -E

    Thanks

    TT

    Leave a comment:


  • David (PassMark)
    replied
    What is the command line that you are using?
    Does the system actually support S3?

    Leave a comment:


  • TinyTim
    replied
    Thank you for your response,

    i get the error message "Sleep time too long warning, Sleep Time 55 seconds"

    The system wakes up after 37 seconds exactly. My test system is running VISTA SP1.

    Thanks

    TT

    Leave a comment:


  • David (PassMark)
    replied
    There is no time limit that we are aware of. Maybe there was some trigger that woke the machine up. e.g. keyboard or mouse movement.

    Leave a comment:

Working...
X