Announcement

Collapse
No announcement yet.

error verifying data in ram / 2d video memory corruption

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • error verifying data in ram / 2d video memory corruption

    Hi

    i just tested some laptops and had these failure messages. sometimes it fails with the "error verifying data in ram" message and sometimes it fails with the "2d video memory corruption" error. The video card is integrated. I tested the memory moduls under dos with memtest86 and they passed, tried them at least in 10 different laptops and they always passed under dos with memtest or mpmemory.
    So basically i would think that the problem is with the motherboard(or with the videocard on it) or withthe cpu. But this problem happened in a lot of different types of motherboard and with different cpus.
    What was the same in those laptops that all of them uses windows vista and integrated video cards.

    we uses burnintest v5.3 pro
    could it be a software issue of this version with the Vista?
    Last edited by jon_snow; 09-24-2009, 01:47 PM.

  • #2
    We investigated a "2d video memory corruption" error earlier this year and found it to be an Intel device driver issue for integrated graphics cards. Intel changed their driver, which changed the behavior.

    I would first think the 2D error is a device driver (which may be common across your laptops).

    The RAM error is more unusual. As you mentioned you tested in DOS with Memtestx86, it would seem your memory hardware is OK. However, as BurnInTest reports an error, I suspect that maybe the 2D graphics test is interfering (at the Operating System/device driver level) with the system RAM. If you remove the 2D test, re-run the test and the RAM error does not occur then I would think it is possibly a graphics card device driver issue.

    I would check you have the latest (integrated) graphics card device driver.

    I don't believe this is a BurnInTest issue. In saying this, we changed the default setting in V6.0 of BurnInTest for the 2D graphics test to test "local video memory" and hence have the 2D test test local video memory, and then use the RAM test to test system RAM. You might try this option.

    Regards,
    Ian

    Comment


    • #3
      All the affected laptops uses the Intel 965 express chipset family and all of them used with 7.14.10.1409 driver (released 1-2-2008 )
      on one of them i updated the driver to the latest vista 32 bit Intel gm965 driver but nothing changed. also tried the last before stable version but i still had the problem. so really dont know what could be problem.
      Tried that i tested all the memories which is installed in a unit and also tried that i just tested the part which is allocated to the video card.

      if it's not a driver problem could it be a 'cause of my settings? what should i check in my cfg?

      thx
      Jon
      Last edited by jon_snow; 09-29-2009, 02:13 PM.

      Comment


      • #4
        We also have had feedback that altering memory voltages can resolve the problem. Here is a related post:
        http://www.passmark.com/forum/showth...ory+corruption

        Regards,
        Ian

        Comment

        Working...
        X