Announcement

Collapse
No announcement yet.

Startup Error Under BartPE

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Startup Error Under BartPE

    I followed the guide at http://www.passmark.com/ftp/BIT_BartPE_v6.0.pdf and other than having to change the plugin inf file to point at bitadmin32.exe instead of bitadmin.exe it seems to have worked.

    However, when I boot up in BartPE in a virtual machine I am getting this when trying to start BurnInTest:

    Error during startup. A problem has occurred with your installation. You may need to uninstall and reinstall the software.
    Contact: www.passmark.com for support.
    Startup Error Number: 1

    Then after clicking OK the program closes. This is with BurnInTest v6.0 Pro. The BartPE image is built with Windows XP SP2.

    I see several potential issues but instead of messing around anymore I figured someone here might have a quick fix or some insight on the problem.

    1) I'm using an evaluation copy. I commented out the reference to key.dat in the BartPE plugin and did not include that file in the plugin folder. I am not interested in buying BurnInTest without seeing it work under BartPE so eval it is. That *seems* to be working ok since the window title under BartPE is: "BurnInTest V6.0 Pro Evaluation version - [Live Results]"

    2) The installed copy I copied to the BartPE plugins folder was from a Vista x64 machine. I did install the 32 bit version of BurnInTest but maybe this is a problem anyway?

  • #2
    It seems we somehow missed uploading the updated BartPE plugin for V6.0 BurnInTest professional. Sorry. We have now uploaded the BartPE plugin, which includes the bitadmin32.exe and DirectX file changes. Please download this here:
    http://www.passmark.com/ftp/bit_bartpe_plugin.zip


    You do need a valid key for the key.dat process to work. For evaulation, we can send you a 30-day trial key. Please email us at our help email address shown on the support page and we will send you a trial key:
    http://www.passmark.com/support/index.htm

    Thanks.

    Regards,
    Ian (PassMark)

    Comment


    • #3
      I have this error also, but I am not using BartPE. I am using Windows PE x86 created with Microsoft OPK Tools (Vista SP1 release) and I am not sure how to install this option. Should I try to install the INF in the BartPE plug-in folder via PEIMG, which is used for installing drivers?

      Comment


      • #4
        I believe this problem (for USB drive installations, BartPE and Windows PE) has been corrected in V6.0.1002, released today:
        http://passmark.com/products/bit.htm

        Regards,
        Ian (Passmark)

        Comment


        • #5
          Sorry for the delay. I tried again using the newest version that you linked to. This time, when I attempt to launch the program using 'bit' or 'bit -p' it does not run. There are no errors, nothing shows up in taskmgr. It just returns to the prompt again, which in my case is x:\windows\burnintest\.

          My setup involves installing the demo on a machine, then copy the folder c:\program files\burnintest and put that folder in my PE source. Then rebuild the PE and boot a client into it.

          Comment


          • #6
            We need to update the documentation for BurnInTest v6.0.1002 (and later). The process for BartPE is now to use the option, File->Install BurnInTest to a USB drive, to get the install files to a temporary directoy and then copy this temporary directory to the BartPE plugin directory (and build the BartPE dsk...).

            Regards,
            Ian

            Comment


            • #7
              Is there any way to get documentation on using this on the standard Windows PE? Currently I am using the one with OPK Tools for Vista SP1 x86 but am now building a Technician PC to start using the Windows 7 x64 PE instead.

              Comment


              • #8
                We have not documented BurnInTest use with Windows PE.

                Around the time we decided to support a PE (years ago), we tried to get Windows PE to do our testing. This was simply too difficult, while BartPE was easy. As such, we have never had a copy of Windows PE to test with. If you would like to provide advice on how we could easily obtain a copy (without dozens of fruitless emails and phone calls), we will investigate as time permits.

                Regards,
                Ian

                [Update: A Win PE installation document is now available as of Aug 2009]

                Comment


                • #9
                  @Tripredacus: I'm currently working on supporting BurnInTest Pro v5.3 under the WinPE from Vista SP1 and the reason BIT is failing to run is most likely due to a missing dependency.

                  Specifically, the "msvfw32.dll" file which you can obtain from Vista and deploy either in WinPE's BurnInTest directory or its system32 directory. You can confirm that being the case though by using Microsoft's Dependency Walker.


                  @Ian: Yes, Windows PE was originally hard to obtain and only available to system builders.

                  Since then though, Microsoft has opened it up and made it publically available as part of the Windows Automated Installation Kit (AIK). The download of the AIK for Windows Vista SP1 is available here.

                  Hope it helps then and looking forward to true WinPE support.

                  Comment


                  • #10
                    @Taco Bell: Thanks. We'll take a look.

                    Regards,
                    Ian

                    Comment


                    • #11
                      Hello again. Still working on this problem of mine. I talked a little with Taco Bell, and while he can get Bit to work in PE 2.1, he does not get the same error. Here is my total experience so far:

                      1. Install on a 2003 computer, works fine.
                      2. Copy that install to the Win PE, gets error 1 (Incorrect Mathematical Addition) during Volume Detection.
                      3. Take the install folder from the PE and put onto an XP computer. This computer is the same one that does the Win PE testing. Run it and Error 1 during Graphics detection.
                      4. Rename the BurnInTest folder on the XP to BurnInTest_Broken. Reinstall BIT. Now both the _broken and the newly installed version run properly.

                      So I did the following:
                      5. Copied over all dependencies I could find (via ProcMon) into the PE. Also copied the Application Data folder into the PE as well, but error still persists.
                      6. I captured a ProcMon of the working (XP) and non-working (PE) installs and they both appear to do totally different things.

                      The first thing that seems to be an issue, is that BIT reads a lot of the information for the installed devices from the Windows registry. In the PE, these items are not in the registry as it uses default Vista drivers to detect and use the installed devices. This may be the problem right there.

                      I can make these two ProcMon logs (PML files) available if you so need them. I also have my full troubleshooting outlined here:
                      http://www.msfn.org/board/index.php?showtopic=132158

                      Please advise. If I can get this to work, my company will be interested in contacting your sales department.

                      Comment


                      • #12
                        It is still on our to do list to test and document the WinPE process.

                        In the meantime, a couple of suggestions:
                        1) You can flag BurnInTest to minimize the amount of system information collected on startup using the command line parameter "-W". Please see help. I would try these.

                        -W
                        Minimize the amount of System Information collected and displayed by BurnInTest. This can be useful for test automation as is can take some time to collect this information and slow test startup. It could also be used to simply reduce the amount of system information in reports. Note: That setting "-W" also sets "-A", i.e. you don't need to specify "-W -A", just "-W".
                        -A
                        BurnInTest will not collect System Information that requires elevated administrator privileges. This is useful for test automation under Windows Vista as Windows Vista would normally prompt with a security message before allowing the collection of the System information.

                        2) Use the latest build of V6.0 (at least V6.0.1006) and use the fucnction, File->Install BurnInTest to USB drive. Install to a temporary location on a hard disk. Use this directory as your basis for your WinPE build. This function creates a directory with all of the files you need for BurnInTest to work from a CD/DVD etc.


                        Regards,
                        Ian

                        Comment


                        • #13
                          Thanks. I will test this out immediately. Hopefully have some results by later today or tomorrow. I am currently waiting on another test unit because my regular one is being used for something else.

                          Comment


                          • #14
                            OK I got my new testing computer and here are my results:

                            using -w, receives error 1 after reading Memory information
                            using -a, receives error 1 while trying to read graphics information

                            When I say "after reading" and "trying to read" I mean, when this error appears, and scroll down the system info page behind the error, this is where the information stops appearing.

                            Comment


                            • #15
                              We have still not tested with WinPE.

                              Did you create the installation using the latest build of V6.0 (at least V6.0.1006) and use the fucnction, File->Install BurnInTest to USB drive. Install to a temporary location on a hard disk. Use this directory as your basis for your WinPE build. This function creates a directory with all of the files you need for BurnInTest to work from a CD/DVD etc.

                              If so, does you WinPE installation have a "key.dat" file in the BurnInTest directory on you WinPE disk?

                              Thanks.
                              Ian

                              Comment

                              Working...
                              X