PassMark Software
Global (Go to Australian site)

Announcement

Collapse
No announcement yet.

Fidelity problem on Windows 7 if sample rates do not match.

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    Ok.

    Just one other thing.

    Your wording in the FAQ is not strong enough IMHO. The fact is that SoundCheck ALWAYS uses what you refer to as the "shared mode" settings. No matter what the user enters into SoundCheck, the hardware will be configured to however it is in the "shared mode" settings. It wasn't like this back on XP, but that's how it is now.

    I referred to this blog indirectly in my first post, but I want to refer to it directly now:
    http://blog.szynalski.com/2009/11/17/an-audiophiles-look-at-the-audio-stack-in-windows-vista-and-7/
    It has some very important information. (says basically what I have been saying, because that's where I got the information to begin with, however I think it's worth a read, nevertheless)

    Greg.
    Last edited by sullivang; 01-10-2011, 11:22 AM.

    Comment


    • #17
      I just did a test to prove that my concern is valid.

      In Windows, I set the sample rate to 48000.
      In SoundCheck, I set the sample rate to be 44100.

      I then played a sine wave test tone, and viewed the spectrum of the input. (I used a loopback cable).

      The input had additional frequencies, other than the frequency of the test tone, DUE TO THE RESAMPLING OF WINDOWS.

      I then changed the sample rate in Windows to match SoundCheck.

      THE RESULT WAS A VERY CLEAN SPECTRUM.

      Btw, this is a nice program. It's good being able to view the spectrum in real time.

      Greg.

      Comment


      • #18
        I repeated the test on Windows XP, and it STILL didn't change the sample rate of the hardware! Arrghh. (I used a USB interface for the test, because it has it's own control panel, and I can monitor the sample rate that it is set to).

        I then tried another sound card test program (a very popular one, it seems), and that did work the way I would want it to - it did change the sample rate of the hardware whenever I changed it in the program.

        So, I was wrong. It is not AS common on Windows XP for the hardware to be automatically configured to match the audio, as I thought it was.

        Greg.

        Comment


        • #19
          Good news. It IS changing the hardware sample rate on Windows XP, but only as long as the requested rate is supported by the hardware. If it isn't, it seems to remain unchanged.
          I can only assume that I had entered one or more unsupported sample rates.

          It would be good if SoundCheck alerted the user if the requested rate was not supported by the hardware. I'm not saying that it should never allow unsupported rates, because it may be required to test the driver's ability to perform sample rate conversion.

          I've re-tested on Windows 7, and I can reaffirm that it NEVER changes the hardware rate. The hardware stays on the sample rate that is set in the Windows device advanced properties.

          Greg.

          Comment

          Working...
          X